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SYMANTEC LICENSE AND WARRANTY
The software which accompanies this license (the "Software") is the 
property of Symantec or its licensors and is protected by copyright 
law. While Symantec continues to own the Software, you will have 
certain rights to use the Software after your acceptance of this li-
cense. Except as may be modified by a license addendum which 
accompanies this license, your rights and obligations with respect 
to the use of this Software are as follows: 

• You may: 

(i) use one copy of the Software on a single computer; 

(ii) make one copy of the Software for archival purposes, or 
copy the software onto the hard disk of your computer and retain 
the original for archival purposes;

(iii) use the Software on a network, provided that you have a 
licensed copy of the Software for each computer that can access the 
Software over that network;  

(iv) after written notice to Symantec, transfer the Software on 
a permanent basis to another person or entity, provided that you 
retain no copies of the Software and the transferee agrees to the 
terms of this agreement; and 

(v) if a single person uses the computer on which the Soft-
ware is installed at least 80% of the time, then after returning the 
completed product registration card which accompanies the Soft-
ware, that person may also use the Software on a single home com-
puter.  

• You may not:

(i) copy the documentation which accompanies the Software;

(ii) sublicense, rent or lease any portion of the Software;

(iii) reverse engineer, decompile, disassemble, modify, trans-
late, make any attempt to discover the source code of the Software, 
or create derivative works from the Software; or

(iv) use a previous version or copy of the Software after you 
have received a disk replacement set or an upgraded version as a 
replacement of the prior version, unless you donate a previous ver-
sion of an upgraded version to a charity of your choice, and such 
charity agrees in writing that it will be the sole end user of the prod-
uct, and that it will abide by the terms of this agreement. Unless you 
so donate a previous version of an upgraded version, upon upgrad-
ing the Software, all copies of the prior version must be destroyed.

• Sixty Day Money Back Guarantee:

If you are the original licensee of this copy of the Software and are 
dissatisfied with it for any reason, you may return the complete 
product, together with your receipt, to Symantec or an authorized 
dealer, postage prepaid, for a full refund at any time during the sixty 
day period following the delivery to you of the Software.
• Limited Warranty:

Symantec warrants that the media on which the Software is distrib-
uted will be free from defects for a period of sixty (60) days from 
the date of delivery of the Software to you. Your sole remedy in the 
event of a breach of this warranty will be that Symantec will, at its 
option, replace any defective media returned to Symantec within 
the warranty period or refund the money you paid for the Software. 
Symantec does not warrant that the Software will meet your re-
quirements or that operation of the Software will be uninterrupted 
or that the Software will be error-free. 

THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL 
OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, INCLUD-
ING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FIT-
NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  
THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU 
MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO 
STATE.

• Disclaimer of Damages:

REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN 
FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT WILL SYMAN-
TEC BE LIABLE TO YOU FOR ANY SPECIAL, CONSEQUENTIAL, 
INDIRECT OR SIMILAR DAMAGES, INCLUDING ANY LOST PROF-
ITS OR LOST DATA ARISING OUT OF THE USE OR INABILITY TO 
USE THE SOFTWARE EVEN IF SYMANTEC HAS BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES.

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION 
OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES 
SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY 
TO YOU.

IN NO CASE SHALL SYMANTEC’S LIABILITY EXCEED THE PUR-
CHASE PRICE FOR THE SOFTWARE. The disclaimers and limita-
tions set forth above will apply regardless of whether you accept 
the Software.

• U.S. Government Restricted Rights:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by 
the Government is subject to restrictions as set forth in subpara-
graph (c) (1) (ii) of the Rights in Technical Data and Computer Soft-
ware clause at DFARS 252.227-7013 or subparagraphs (c) (1) and 
(2) of the Commercial Computer Software-Restricted Rights clause 
at 48 CFR 52.227-19, as applicable, Symantec Corporation, 10201 
Torre Avenue, Cupertino, CA 95014.

• General:

This Agreement will be governed by the laws of the State of Cali-
fornia. This Agreement may only be modified by a license adden-
dum which accompanies this license or by a written document 
which has been signed by both you and Symantec. Should you 
have any questions concerning this Agreement, or if you desire to 
contact Symantec for any reason, please write: 

Symantec Customer Service, 175 W. Broadway, 
Eugene, OR 97401.



 

License and Warranty Addendum

 

The software you are acquiring has been specially configured to run on a network, and consequently 
Symantec grants to you the right to use the enclosed Software on a computer network provided that for 
each and every concurrent user on the network, you have acquired and dedicated one licensed copy of 
the software.
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C H A P T E R 1
Welcome to Visual Page

Symantec® Visual Page™ is an easy-to-learn, easy-to-use, truly WYSIWYG 
(what-you-see-is-what-you-get) visual Web page editor. 

If you are new to Web page building you’ll appreciate using Visual Page to 
drag and drop elements into your Web page without having to learn the 
Web’s markup language, HTML.

Of interest to the more experienced Webmaster, Visual Page generates 
excellent HTML code and includes a source editor. Changes to the source 
editor are instantly reflected in the visual editor and vice versa.

This chapter familiarizes you with some of the basics of getting started with 
Visual Page. It contains the following sections:
■ About this book
■ About the Web
■ About Visual Page 

If you are confident with your knowledge of the Web and its associated 
vocabulary, you can skip “About the Web” and go to “About Visual Page” 
on page 1-7. 

In addition to this book, the Visual Page User’s Guide comes with the 
Visual Page application. Consult the User’s Guide for detailed descriptions 
and explanations of all of the Visual Page features and concepts. Online 
help is also included with the application.
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Chapter 1: Welcome to Visual Page

                                 
About this book
In this book you will find:
■ An overview of Visual Page — in this chapter
■ Installation instructions in Chapter 2
■ A walkthrough of the Visual Page Tour Web site in “Welcome to 

Visual Page” on page 1-1
■ Steps for “Building the Amazing Adventure Web pages” on page 4-

1, in which you:
■ Build a new Web page on “Creating the Customer Comments 

Web page” on page 4-2
■ Create a Web page layout in “Creating the island photo layout” 

on page 4-8
■ Format a Web page using tables in “Creating the Package Tours 

table” on page 4-15
■ Place text fields and buttons in “Creating the reply form” on 

page 4-28
■ Steps for adding interactivity to your Web pages in “Adding life to 

the Amazing Adventures Web site” on page 5-1, including:
■ “Creating movement on the Home page” on page 5-2
■ “Making the map clickable” on page 5-7
■ “Creating a working Table of Contents” on page 5-15
■ “Publishing your Web site” on page 5-19

■ Customer support information in Chapter 6

The files you need for the tour are installed for you when you install Visual 
Page using the Typical (default) installation. 

About the audience

This book assumes that you are familiar with and know how to perform 
standard Windows 95 operations, such as: clicking and dragging, double-
clicking, opening and closing files and applications, and saving changes. If 
you need help with these, see the online help that installs with the 
operating system. You can access it by choosing Help from the Start menu. 
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About this book

                            
Why use this tour

If you want to experience the excitement of easily building a Web page 
from beginning to end, you should work through the tour presented in this 
book. 

Using the Visual Page tour, you will become familiar with the Visual Page 
application by following detailed procedures for building a working Web 
page. This tour requires no previous experience in Web Page authoring or 
HTML coding. 

As you build the Web pages needed to construct the Amazing Adventures 
Web site, you will learn to use many of the Visual Page features, including:
■ Creating a plain Web page
■ Creating a Web page with frames
■ Importing text and graphics,
■ Adding and running Java applets
■ Flowing text around graphics
■ Creating and modifying a table
■ Linking text and graphics
■ Using image maps and anchors
■ Creating an e-mail form

Typographic conventions

The following typographic conventions are used throughout this book:

Convention Meaning

Computer voice Text, which is exactly as it appears on your 
computer, is in computer voice style.

Bold At the first occurrence of the definition of a 
term, it is in bold text. 
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About the Web
The Internet is a global set of interconnected computers, like the network 
you may use at work or school, but on a larger scale. It has been in use for 
over thirty years but the Internet has only recently become popular. This is 
primarily due to the World Wide Web (otherwise known as the Web or 
WWW) — the “front end” of the Internet — which supports graphics, 
animation, and sound. 

The following sections help familiarize you with the concepts and 
vocabulary associated with the Web:
■ Publishing on the Web
■ Understanding links and locators

Publishing on the Web

You use Visual Page to construct and publish documents for the World 
Wide Web. These documents, known as a Web pages, are stored on an 
Internet server and displayed by the Web browser on your computer.

Web browsers display Web pages by interpreting the special HyperText 
Markup Language (HTML) tags which are used to encode Web pages with 
display information. When you use Visual page, it takes care of adding the 
HTML tags, while you move parts of the Web page into place in a visual 
representation of the Web page. 

Web pages usually are linked to many different files, such as graphic and 
multimedia files. You typically keep these files in a folder or set of folders 
on your disk drive, while you construct your Web site. This folder is 
known as your local Web site. 

This site’s collection of linked files and Web pages are typically tied 
together into a cohesive collection of information by a home page. The 
home page typically contains a topic list which links it to other Web pages 
in its Web site.

When you publish your Web site, you upload the local site folder (and its 
contents) to a Web server, which contains the software that “serves” your 
Web page out to Web browsers on computers that are connected to the 
Internet. Once your local site is published to the Web server, it becomes a 
Web site.
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About the Web

                           
A data protocol called the File Transfer Protocol (FTP) is required to 
upload and download files from your system to and from a Web server. 
Visual Page provides extensive FTP support, including the ability to 
upload, download, and modify server-based files. For more information 
see the Visual Page User’s Guide.

Understanding links and locators

Web page links are specially formatted text or graphics that, when clicked 
on, display more text or graphics. These files may include other Web pages 
or files with different kinds of multimedia, pictures, sound, animation, 
entry forms, Java applets, movies, and more. 

Links use URLs to locate other Web files. An URL (uniform resource 
locator) is kind of address for a Web file. When you create links using 
Visual Page, you can see the URLs which Visual Page generates. 

The following example shows a hypothetical URL:

Refer to the above URL as you read the description of its parts:
■ Protocol: rules governing the transfer of data over the network; the 

Internet uses the HyperText Transfer Protocol: http
■ Domain: host name and Internet namespace: 

www.Symantec.com 
■ Directory path: the relative location of the file: tools/docs
■ File name: the Web page, graphic, or sound file:

User Guide.html

■ Anchor: a marker which identifies a location inside a file to which 
you can link. 

In the island map Web page, which you’ll work on in the tour, a mouse 
click on the map at the top of the Web page scrolls it to the appropriate 
title further down on the page because map locations are linked to anchors 

http://www.symantec.com/tools/docs/User Guide.html

Protocol Domain Directory path File name
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which you place in the text. You can see an anchor in the following 
illustration:  

For more information about links and anchors, see the “Visual Page User’s 
Guide.” 

lnked to anchor

Anchor 

Map location is
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About Visual Page
Where to find more information

If you want to understand more about the World Wide Web, there are 
many books that explain the Internet, Web pages, and the Web’s 
underlying language, HTML. They may be found at all levels of complexity. 

Following are some useful books which you can use to quickly understand 
the basics of HTML and the Internet:
■ How to Use HTML 3, by Scott Arpajian (Ziff Davis Press)
■ HTML Visual Quick Reference (2nd ed.), by Dean Scharf (Que 

Books)
■ Internet and World Wide Web Simplified, by Ruth Maran (IDG 

Books)

For more in-depth discussions and advanced topics, see the following:
■ The Internet Book, By Douglas Comer (Prentice-Hall, Inc.)
■ Web Publisher’s Design Guide, by Mary Jo Fahey (Coriolis)
■ Elements of Web Design, by Darcy DiNucci, with Maria Giudice and 

Lynne Stiles (Peachpit Press)
■ Designing Large-Scale Web Sites, by Darrell Sand (Wiley Computer 

Publishing)
■ WebMedia Magic, by Kevin Hampton (IDG Books)

About Visual Page
To illustrate Visual Page’s features, the Visual Page tour will have you use 
Visual Page to create the tour’s Web pages. When you’re using the visual 
editor you drag and drop contents like movies, graphics, tables, and links 
into your Web page. Visual Page automatically generates the HTML source 
required to display the Web page. 

There are many Visual Page tools and features. The tour introduces you to 
a subset. You can find the rest documented in the “Visual Page User’s 
Guide.” 

The following sections introduce the Visual Page feature set:
■ Local Site windows
■ FTP Web site publishing
■ Java support
1-7
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■ Two-way visual and source editors
■ Web page templates
■ Summary of Visual Page features

Local Site windows

As an aid to building your Web page and Web site, Visual Page has a 
unique Local Site window utility that provides easy access to your local 
Web site. The Local Site window facilitates drag-and-drop operations and 
allows you to easily locate the files you are using in your Web site. 

FTP Web site publishing

After a Web site is finished you can use Visual Page to connect to an FTP 
server and publish your files to a Web server. When you put a document 
on the Web, users who have access privileges can view it by using their 
local Web page browsers to access it on the World Wide Web.

Java support

Visual Page supports the Java Virtual Machine. This enables you to 
dynamically preview Java applets  on any Windows 95 or NT 4.0 machine 
as you develop a Web page. Visual Page also  supports Web browser plug-
ins.

Two-way editing

Visual Page’s two-way editing system includes a visual editor and a source 
editor. You use the visual editor to add visual elements like graphics, 
animations, and text to your Web page, and use the source editor to 
display and edit the HTML tags Visual Page generates. 

You will see in the Visual Page tour that you can even place the source 
editor next to the visual editor and watch the HTML tags generate as you 
change items in your Web page. 
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About Visual Page
The following illustration shows two views of the Amazing Adventures 
opening Web page; one in the visual editor and the other in the source 
editor:

The visual editor

As Web pages have become more visually sophisticated, page layout has 
become more important.When you use the Visual Page visual editor, you 
directly manipulate the layout of display elements like text and graphics. 
The HTML code for displaying these items is generated simultaneously by 
Visual Page but it is normally hidden from view. So, you get to see your 
Web page as you put it together. And, it looks almost exactly the same as 
the finished Web page will look in a Web browser. 

Before tools like the visual editor in Visual Page became available, 
programmers had to manually enter HTML tags and URLs for Web pages by 
using a text editor or word processor. To see the Web page display they 
had to leave the text editor and open the HTML text file in an external Web 
page browser. 

Visual editor Source editor 
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The source editor

If you want to see or edit the HTML source, you can use the source editor 
to do so. Visual Page instantly generates the corresponding HTML source 
as you insert Web page elements in the visual editor.

The HTML source editor provides color-coded text and a toolbar 
corresponding to the Web page elements. When you make a choice from 
the toolbar, the appropriate HTML for each element is automatically put 
into the source at the insertion point. Conversely, when you edit the HTML 
source, the appropriate graphic representation is displayed in the visual 
editor Web page view. 

See the Visual Page User’s Guide for more detailed information about the 
source editor.

Web page templates

When you install Visual Page, you can elect to have the installer place an 
extensive set of professionally-designed Web page templates and graphics 
on your disk drive. After you finish the tour, you can pick and choose 
amongst these and use them as a basis for your own Web pages. They 
include professional graphic elements like buttons and backgrounds for 
you to incorporate into your own Web pages. By using these, even novice 
users can quickly and easily create professional looking documents. 

What’s next
The next chapter of this book contains instructions for installing Visual 
Page procedures. You must install the software before going ahead to the 
walkthrough of the Amazing Adventure Web site in “Introducing the 
Amazing Adventures Web site” on page 3-1. The construction of the Web 
Site begins in Chapter 4.
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C H A P T E R 2
Installing Visual Page

This chapter contains:
■ System requirements for Visual Page 
■ CD-ROM installation instructions

If your system includes a CD-ROM player, the easiest way to install the 
application is by using the CD-ROM disk that comes with the application. 
Otherwise, you must install Visual Page with floppy disks. 
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System requirements
To run the Visual Page application, you must meet the following platform 
requirements:
■ IBM PC or 100% compatible
■ Windows 95 or Windows NT 4.0
■ 486/66mhz or above
■ VGA video or better is recommended; 256 colors or more are 

required for previewing Java applets
■ 8 megabytes of RAM for Windows 95
■ 12 megabytes of RAM for Windows NT
■ 18 megabytes of hard drive space for full installation
■ 3 megabytes of hard drive space for compact installation 

CD-ROM Installation
When you use the easy installation option, the installer determines your 
platform and automatically installs the appropriate version of the 
application. 

To perform the easy installation of Visual Page:

1 Insert the Visual Page CD-ROM disk icon.

It automatically launches the Setup application. 

2 Read the instructions on the initial page and click Next. 

3 Read the Software License Agreement. If you accept the conditions 
for use of the software, click Accept. The Sun Microsystems 
Software License Agreement is also included because Visual Page 
uses Java. If you accept the conditions for use of the software, 
click Accept.

The following screen displays installation options. 

4 To go ahead with the installation, choose one of the installation 
options. The two preset options are the Typical and Compact 
installation. If you want to determine exactly which pieces of the 
application to install choose the Custom installation. 

5 On the same screen, choose the directory location where you want 
the application to reside, then click Next. 
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Floppy disk installation
6 Verify the application folder on this screen and reset it if necessary, 
then click Next. 

A screen with the current settings for placement of the application 
displays. 

7 If you agree with the settings, click Install. Otherwise, you may 
click Back to reset the directory or Program folder, or click Cancel 
to stop the whole process. 

8 If you click Install, a Setup progress indicator displays. 

At the end of the installation a question displays.

9 To read the ReadMe file, which contains tips for use of the product 
and late-breaking information, click Yes. 

To do a custom installation of Visual Page:

1 Follow steps 1-5 above.

2 For step four, choose Custom on the installation option screen. 

3 Select the items you choose to install and click Next.

4 Continue with steps 6-9, above.

Floppy disk installation
If you do not have a CD-ROM player, look for information about ordering 
the floppy disk installer in “Disk Exchange and/or Replacement Form” on 
page 6-11.
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C H A P T E R 3
Introducing the Amazing 
Adventures Web site

In this chapter you will walk through a finished version of the Amazing 
Adventures Web site. You should go through this introduction to the Visual 
Page tour so you can become familiar with the Web pages which you are 
going to start building in the next chapter. 

While walking through the Amazing Adventures Web pages you will:
■ Look at the Amazing Adventures Web Site by using a Visual Page 

Local Site window
■ View the animation 
■ Experience the workings of the Amazing Adventures Web site 
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What you need
Before you begin, you must install the Visual Page software, as described 
in “Installing Visual Page” on page 2-1. Make sure you installed the Java 
support folder for Visual Page or your applets will not work. After this is 
done, look for the Tour folder, inside the Visual Page folder (which is at 
the disk location you chose when installing Visual Page.) It contains the 
files you’ll need to construct the Web pages for the tour. You’ll also find a 
finished version of the Amazing Adventures Web site, in the folder named 
Walkthrough, which you’ll use in this chapter to get acquainted with the 
Amazing Adventures Web pages. 

Setting the scene
Imagine that you are an ambitious and creative employee of a travel 
agency, called Amazing Adventures Travel. You start “surfing the Web” and 
after seeing your competitors’ Web pages you convince your colleagues 
that it’s time your travel agency take advantage of the ability to reach more 
customers through the Web. You’re so enthusiastic about the possibilities 
that you end up with the assignment to build the Web page. 

In order to start work on a new Web site, you must typically accomplish 
the following:
■ Identify your goals. First you get some idea of your competition’s 

Web pages, then you identify what you want the Amazing 
Adventures Web site to accomplish. 

■ Outline the content. This step creates your roadmap. 

Identifying goals for the Web site

You have an idea of what you want to see in a Web page after visiting the 
competitor’s sites on the Internet. This enables you to determine the 
following goals in preparation for building the Amazing Adventures site:
■ The purpose of the Amazing Adventures Web site is to cultivate 

new potential customers. 
■ The tone of the writing should speak to an audience of educated, 

computer-savvy people. 
■ The information you plan to offer must be easy to find and view. 
■ The Web pages must attract and keep the attention of your visitors 

by being interactive and entertaining. 
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Setting the scene
Outlining the general content

The Amazing Adventures travel agency decides that its Web site should be 
a kind of on-line travel brochure. The overall look should be one that is 
clean and bright. In general, the backgrounds are going to be white with 
the graphics done in a bright, tropical color scheme. 

Since the most popular trip the agency offers is to the tropical island, “Isle 
de Cafe,” you want to showcase it as an example of what the Amazing 
Adventures agency has to offer. You plan to use the Web site to show off 
pictures of the island, describe its locations, and offer information about 
the different Isle de Cafe tours. The agency also wants you to use some of 
the favorable customer comments they’ve received from past trips. 

While surfing the Web to check out the competition, you saw some Web 
pages that were divided so that part of the text and graphics always stayed 
in one area of the Web page. You plan to use this concept in the Amazing 
Adventures home page to make the site easy to navigate. 

The thought is to divide the home page into a Table of Contents, which 
contains icons that are linked to the other Amazing Adventures Web pages. 
From now on we’ll call the Table of Contents the TOC.

The TOC always appears on the left of the home page. Since it never 
moves, the TOC frame is a kind of landmark for your Web site visitors as 
they navigate through the information in the other Web pages in the 
Amazing Adventures Web site. To the right of the TOC, a larger frame will 
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display the Web pages which are linked to the icons in the TOC frame. A 
sketched outline of the home page looks like this:

In the next portion of the tour, you are going to use Visual Page to take a 
look at the finished version of the Amazing Adventures Web site. 

TOC icons

Talk.htm

Opener.html

Map.html

Reply.html

Tours.html

Web pages
linked to 

Island 

Customer
Comments
icon

Custom
Tours 
icon

icon
map

icon
page

E-mail 
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Text 
describing
photo

 

Home 

TOC frame

TOC icons

Display frame

currently
displaying

l
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Walking through the finished Web site
The Walkthrough folder is a provided for you to use with this guided tour 
of the finished version of the Amazing Adventures Web site. In it you will 
see the Web pages as they will appear after you finish building them. You’ll 
begin building the Web pages in the next chapter. 

Opening the Walkthrough Local Site window

You’re going to use the Visual Page Local Site window to get acquainted 
with the Amazing Adventures Web site. As you’ll find out later in the tour, 
the Local Site window is also useful for many drag-and-drop operations, 
from browsing the Web site files to adding links and graphics to Web 
pages. 

To open the Walkthrough Local Site window, you must first open your 
Visual Page application, if it’s not already open. One way to start the 
application, is to choose Programs > Symantec Visual Page from the Start 
menu. 

From the File menu, choose Open Local Site and use the dialog box it 
displays to find and select the Walkthrough folder from the file list. It’s at 
the root level of the Tour folder, which is inside the Visual Page folder.

Select this folder

Then click OK
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Chapter 3: Introducing the Amazing Adventures Web site
When you click OK, the Local Site window displays:

Notice that the controls in the Local Site window, which are labeled in the 
following illustration, are similar to those in the Windows Explorer. If you 
click once on a plus which is next to a folder, it becomes a minus and 
displays the contents of the folder. Similarly, if you click once on a plus 
which is next to a folder in a Local Site window, it shows the contents of 
that folder.

If you click on a plus that is next to a Web page in a Local Site window, it 
becomes a minus and displays the anchors in that Web page. Try this and 
your Local Site window looks like this:

You’ll use this later in the tour to drag and drop anchors. (See “Making the 
map clickable” on page 5-7.)

Also notice the different kinds of files the Local Site window contains. 
These include the graphics, text, and multimedia files used in and linked to 
the different Web pages in the Amazing Adventures Web site. 

At the root level of the Walkthrough Local Site window, notice the eight 
files with .html filename extensions. These are Web page files, which you 
can display in a Web browser or Visual Page. 

You can also see two Java applet files at the root level of the Walkthrough 
folder. These are recognizable by their .class filename extensions. Java 
applets are like mini-applications that only work on a Web page. The 
folder, named Symantec, which is also at the root level of the Walkthrough 
folder, has the Java code required by the Java applets which are used in the 

Plus expander 

Anchor symbol

Web page

Java applet
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Tour. If you move the folder or remove files from it, the applets won’t 
work. 

The Images folder, which is also at the root level of the Walkthrough 
folder, contains the graphics for the Amazing Adventures Web site. To see 
the list of files and folders which are in the images folder, click once on the 
plus next to the images folder. 

After you click, the plus becomes a minus and you see a lot of GIF 
(graphic interchange format) files with the filename extension .gif. The 
GIF file format is one of the kinds of graphic formats which you can use in 
Web pages. The other graphic format is called a JPEG file. See the Visual 
Page User’s Guide for more information. 

Now let’s take a look at the contents of the text folder. Click once on the  
plus that is next to the Text folder. The plus becomes a minus and you see 
the list of files the Text folder contains. You’ll use these text files to add 
text to a Web page in the tour. 

Look again at the contents of the Walkthrough Local Site window. As with 
any Web site you intend to publish to an Internet server, the Amazing 
Adventures Site adheres to certain folder and file naming conventions 
required by the server software. As you look at the Local Site window 
again, notice the organization and naming rules to which this Web site 
adheres, including:
■ Putting the graphics in an Images folder
■ Keeping all folders and files together in a single Web site folder
■ Naming the starting Web page, home.html

Finally, there is one more thing about the Local Site window you should 
notice. Look at the Window menu items. The name of the Local Site 
window which you opened is now displayed as a menu item. This makes it 
easy to find the window, when you’re working with multiple open 
windows.

Previewing the opening page

In the following steps you are going to use the Preview mode of Visual 
Page to try out a working copy of the home page. In Preview mode you 
can see the Java applets working without leaving Visual Page. Also in 
Preview mode, you can click on links to see how they work. Since the 
links are live, you can get a feel for browsing the Web site, without leaving 
Visual Page. 
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To preview the contents of the Home page, double-click on the file icon 
for home.html. in the Local Site window. When you do this, the home 
page displays, as shown in the following picture:

If you installed the Java support folder for Visual Page you’ll be able 
to see the applets work by switching to Preview mode. 

To switch to Preview mode, click on the Preview toolbar button, (shown at 
the left.) Otherwise, if you did not install the Java support folder, you can 
choose Preview in Browser from the View menu to see the applets 
working on the Web page from your Web browser.

When you choose Preview in Browser, the browser application which you 
have on your machine launches. The home page then displays with the 
applets running. The plane animation displays with the plane tilting back 
and forth, the propeller whirling, and the pilot’s scarf blowing in the wind. 

Java applet

Toolbar
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The slide show applet displays its first photo, as shown in the following 
picture:

Linked TOC icons

Web page display frame showing the 

Applet running

Applet running

Table of Contents frame

Click here

opening Web page: Opener.html
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Interacting with the home page

Now, try clicking on the right arrow of the slide show controller. Notice 
that the island photo and its description change. That’s because the slide 
show applet is running now. 

In addition to the slide show, you can interact with this Web page by 
clicking on one of the TOC icons to display another Web page. As you do 
this, notice that each of the Table of Contents icons is linked to a different 
Web page. Click on each TOC icon to display the following Web pages: 
■ Home page and Slide Show icon: displays an interesting opening 

page (Opener.html) which has animation, graphics, and an 
applet slide show 

■ Island Map and Information icon: links to the island map page 
(Map.html) which contains a map and information about its 
towns 

■ Client Comments icon: links to a client comments page 
(Talk.html) with quotes from previous happy customers 

■ Custom and Package Tours icon: displays a page listing the 
available Isle de Cafe tours (Tours.html)

■ E-mail Request Form icon: links to an e-mail form (Reply.html) 
that electronically transmits customer information and requests 

You’ve seen the opening page already: it’s what displays next to the TOC 
when the home page first opens. It was also shown in the previous 
illustration. In the following sections, you will explore some of the other 
pages. 
3-10



Walking through the finished Web site
Using the island map page

With the home page open and Visual Page in Preview mode you can see 
the island map page in the display frame, by clicking on the Island Map 
and Information icon. When you do, you’ll see the following:

Notice that what you see in the display frame is only part of the Island map 
page. You can use the scroll bars, which Visual Page has automatically 
added, to see the rest of the page. Or, you can click on any location shown 
on the map, at the top of the Web page, to automatically scroll the Web 
page to the corresponding title. 

To scroll the Web page automatically from the map, move the mouse over 
any location name on the island map. When you do this, notice that the 
arrow pointer changes to a pointing finger, indicating that the mouse is 
over a link. Go ahead and click the mouse. The Web page scrolls to the 
title that matches the location name. You can try this again with any of the 

Click on
map
location

Page 
scrolls 
to title 
3-11



Chapter 3: Introducing the Amazing Adventures Web site
locations on the map. Later in the tour you are going to create the links 
that make the map page function like this. 

When you’re finished exploring this Web page, close the home page and 
continue on to see the Customer Comments page.

Looking at the Customer Comments Web page

The Customer Comments Web page is an uncomplicated page, containing 
one graphic and the contents of a text file. Since the Web page itself is 
simple, this is a good opportunity to have you look at the HTML source 
editor. This is mainly for your information; you don’t actually use the 
source editor anywhere in the Visual Page Tour. 

To view the Customer Comments Web page by itself, double-click on 
talk.html in the Local Site window. The Customer Comments Web page 
displays, as shown in the following picture:

Graphic 

Comments imported
from text file
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There’s nothing to interact with on this Web page, so let’s look at the 
source view. To see the Customer Comments source view, click the Edit 
Source toolbar button (shown at left). 

The source editor displays, as shown in the following picture: 

The source is the part of the text which is made up of HTML tags, which 
you can identify by the opening and closing brackets (< >) around them:

You can easily see the relationship between the visual editor and the 
source editor by trying a little experiment. Switch to the visual editor by 
clicking anywhere in it. Keep the source editor open and arrange the two 
windows so you can see both.

In the visual editor, double-click on the word “spectacular” in the first 
testimonial paragraph, to select it. While spectacular is selected, click on 
the Bold toolbar button (shown at left.) The word “spectacular” now 
displays in bold on the Web page. 

Watch closely as you switch to the source editor by clicking anywhere in it. 
The bold tags appear in the source editor as soon as you activate the 
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window! You should be able to spot them easily with a color monitor. The 
following picture shows the two views:

The same experiment also works in reverse. In other words, you can insert 
the tags directly into the HTML source text and then switch to the visual 
editor to see the changes you made in the visual display of the Web page. 

When you’re finished, make sure to close both views of the Customer 
Comments Web page — without saving changes. For more information 
about the source editor, see the Visual Page User’s Guide. 

In the following section, you will browse the final two Amazing 
Adventures Web pages. 

First select the
word and 
make it Bold

New tags for bold text
appear when you switch
to source view 
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Browsing the Custom Tours and e-mail Web pages

Since trips are the main business of the Amazing Adventures Travel 
Agency, there has to be a Web page that presents the tours. You are going 
to do this in a table format on the Custom Tours Web page — so that the 
specific information for each tour is easy to see. See “Creating the Package 
Tours table” on page 4-15. 

To open the Custom and Package Tours Web page, double-click on 
Tours.html in the Local Site window. Notice that the Custom Tours Web 
page, which is shown in the following illustration, also contains a link to 
the e-mail form Web page:

To browse the e-mail page: 
■ Click the Preview toolbar button to go to Preview mode
■ Then click on the underlined text “send us e-mail” 

Linked text 

Table
3-15



Chapter 3: Introducing the Amazing Adventures Web site
The e-mail form displays. It is shown in the following picture, (minus a few 
text boxes so some of each kind of user interface element shows):

The text boxes and buttons on this page are known as form elements. 
These are labelled in the above picture. You are going to build the e-mail 
form later in the tour.

Text box 

Radio buttons

Scrolling text area

Buttons for sending
e-mail or clearing 
text
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What’s next
In this introduction you saw many of the Web page features you’ll be using 
to build a Web site in the Visual Page tour. These included:
■ A Home page with two frames
■ The Customer Comments Web page, with its imported text and 

title graphic
■ A clickable map on the Isle de Cafe Web page
■ A working Java applet on the opening page
■ The Custom Tours table
■ An e-mail form

The procedures for building these Web pages make up most of the rest of 
this book. By the time you have finished the tour, you will have created the 
working Web site you just previewed. 

Note: If you own a copy of Symantec’s Visual Cafe, you can build the Java 
applets used in this tour by following the Visual Cafe tour. See “Getting 
Started with Visual Cafe.”
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C H A P T E R 4
Building the Amazing 
Adventure Web pages 

In this chapter you will construct several Web pages for the Amazing 
Adventures Web site. While doing this, you’ll learn to:
■ Create a new Web page
■ Add graphics and text to the new Web page
■ Use a table to format the information for the Custom Tours 
■ Create an e-mail reply form
■ Layout pictures with text that describes the Isle de Cafe

In doing these things, you will build the Customer Comments Web page 
from scratch and complete most of three others, including: the Custom 
Tours, E-mail Reply Form, and Island Map Web pages. 
4-1



Chapter 4: Building the Amazing Adventure Web pages
Creating the Customer Comments Web page
Customers have been writing comments in a visitor’s log during previous 
Isle de Cafe tours. Your agency wants to make the favorable comments 
available on the Web site for visitors to read. 

You decide to make the design of this page plain, like an actual visitor’s 
log, so the focus is on the text. While authoring this Web page you are 
going to:
■ Create a new Web page and set its background color
■ Import the customer comments from a text file
■ Add a title graphic

Note: This chapter assumes you know how to open a Visual Page Local 
Site window. If you need instructions, see “Opening the Walkthrough Local 
Site window” on page 3-5.
4-2



Creating the Customer Comments Web page
Opening the new Web page

To preserve a guest book feel to the Customer Comments Web page, you 
want to keep the layout simple. To achieve this you decide to place the 
comment text on a plain white background. 

In the following procedure you open a new Web page and set its 
background color to white.

To create the blank Customer Comments page:

1 Open the Visual Page application. 

An untitled Web page displays. It looks like the following picture:

Note: If the new Web page gets closed for any reason, you can 
open another one by choosing New from the File menu.

New Web page
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2 From the Edit menu, choose Properties > Page. 

The Page Properties dialog box displays, as shown in the following 
illustration: 

3 Type “Customer Comments” in the Page title field. 

This title is used in the HTML source. It also displays in the title bar of 
the Web page when it is displayed by a Web browser.

4 In the same dialog box, click the Background button of the Colors 
group, to display the drop-down color well. 

5 When the color well displays, click its white square. 

Click here to display color well 
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Creating the Customer Comments Web page
6 Click Apply and the white background displays on the Web page 
before the dialog box closes, as shown in the following picture: 

7 Click OK to close the dialog box. 

8 Choose Save As from the File menu. 

9 Use the Save As dialog box to save your file as as talk.html at 
the root level of the Tour folder. 

After the file is saved, talk.html displays in the title bar of the Web 
page. 

White background 
on Web page
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Adding the customer comment text

Since the customer comments from previous travelers are in a text file, you 
are going to import that text rather than retype it into the Web page. 

To add the customer comments to the Web page:

1 Position the Tour Local Site window to the side of the Web page, 
as shown in the picture below. The talk.html Web page should 
be already open and displaying. 

2 In the Local Site window, open the Text folder by clicking on the 
plus next to the folder. 

3 Drag Comments.txt from the Local Site window and drop it on 
the Web page. 

The text instantly displays and your desktop looks similar to this: 

Drag and drop 
the text file on 
the Web page
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Adding the Customer Comments title graphic

The finishing touch to this page is the colorful title graphic. In the 
following steps you use the Local Site window to drag and drop the title 
into place on the Web page. 

To insert the Customer Comments graphic:

1 Using the Local Site window, locate Comments.gif in the 
Images folder. To do this, click once on the plus next to the 
Images folder.

The plus becomes a minus and the files in the Images folder display. 

2 Create a blank line before the first quote in talk.html. 

3 Drag Comments.gif from the Local Site window and drop it on 
the blank line at the top of the Web page. 

The following picture shows the finished Customer Comments Web 
page, after you add the title banner:

4 Make sure to save your work and close this Web page file.

Title banner 
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Creating the island photo layout
A map of the Isle de Cafe makes an interesting illustration for the Web 
page that describes each of its locations. You devote a whole Web page — 
the Isle de Cafe Web page — to information about the different Isle de 
Cafe towns. 

This Web page is going to be fairly long because there are four locations 
on the map which you want to describe in some detail. To make the length 
of the page more manageable, you decide to make the locations on the 
map respond to a mouse click that automatically scrolls the page to the 
appropriate description. 

In order to finish the layout of the Isle de Cafe Web page, you are going to:
■ Left-justify a photo so that text flows around its right side
■ Add another photo and resize it to fit the Web page
■ Right-justify the newly added photo so text flows around the left of 

the image

Flowing text around a photo

As in a traditional travel brochure, you are going to use pictures to 
illustrate different places on the Isle de Cafe. To make the layout look 
professional, the text needs to flow around each photo. In the following 
steps you’ll add the text that describes parts of the island around an island 
photo. 

To flow descriptive text around the right side of the first photo:

1 From the Tour Local Site window, open the Map.html Web page. 
(It’s at the root level of the Tour folder.) 

2 Select the photo, directly under the Bungbusi heading, by clicking 
once on it.
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The selected photo displays with a dark outline and handles, as 
shown in the following picture:

3 From the Format menu, select Object Alignment. 

This picture should have Left Object Alignment checked. 

4 Place the Local Site window in front of the Web page. 

Select this photo
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5 Drag map1.txt from the Text folder of Local Site window to the 
top right side of the Bungbusi photograph, as shown in the 
following picture:

When you drop map1.txt on the Web page, the text instantly flows 
around the right side of the picture. The left aligned island photo 
displays at the left of the paragraph, with the text flowing around its 
right side, as shown in the following illustration:

Drop text file here

Left-aligned graphic
with text 
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Reducing a Bungbusi photo 

On the Isle de Cafe Web page you are really reusing the photos from slide-
show. That way you only need one copy of the GIF photo files, which are 
stored in the images folder of the Web site. They are the correct size for the 
slide show but too large for this Web page. (For more information about 
the slide show see “Previewing the opening page” on page 3-7 and 
“Adding the interactive slide show” on page 5-6.) So, you need to reduce 
the photo sizes when you use them on the Isle de Cafe Web page. The 
following steps help you resize a photo to add to the Bungbusi section. 

To add the Bungbusi photo:

1 Drag Photo_8.gif from the Images folder in the Local Site 
window and drop it below the text you added in the previous 
procedure. 

The photo should display as shown in the following illustration:

The .gif file 
displays 
immediately
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2 Double-click on the newly inserted photo.

An Image Properties dialog box opens.

3 Resize the image to the size of the other photos by setting its 
Width to 177 and its Height to 122.

4 Add white space around the photo by setting Horizontal Space 
Around Image to 5. 

The settings should look like this

5 Press Enter or click OK to close the dialog box.

The picture instantly shrinks to the correct size.

6 It’s a good idea to occasionally save your changes, so do that now, 
if you haven’t already. 

Setting a photo to the right of the text

To vary the layout some, you want to have pictures on alternating sides of 
the text. Each island town has two photos — the first displays to the left of 
the text, so the second needs to display to the right of the text. 

To place the second photo on the right side of the Web page:

1 Select the photo that you just placed on the map page, (it’s the 
second photograph from the top) by clicking once on it.

It displays with an outline and dark handles:

2 From the  Format menu, select Object Alignment > Right. 

The picture moves to the right of the Web page.

Adds whitespace
around photo

Use these to 
resize photo
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3 Drag map2.txt from the Local Site window, it’s in the Text 
folder, and drop it at the top left side of the photograph. 

When you do so, the text wraps around the left side of the photo:

4 Select any empty lines left between the text you just added and the 
Venduca heading and delete them by pressing the delete key.

Drop the text here
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The Bungbusi section of the Isle de Cafe Web page now looks like 
this:

Styling the paragraph titles

After placing the descriptions next to the island photos, you want to create 
easily seen titles for the different Bungbusi sections. Since the traditional 
HTML heading styles require a title to appear on a separate line, you 
decide to use a bold style word at the beginning of a line. This fits in better 
and still draws attention to the content. 

To make the one word headers bold:

1 Select the word “Activities” at the beginning of the second 
paragraph of the Bungbusi text.

2 While the word is still selected, choose Bold from the Style menu.

Left-aligned image

Right-aligned image
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Click outside the word to deselect it. It is now displaying in bold style 
text:

3 Repeat steps 1-2 for the title words — Sports, Shops, Dining, and 
Accommodations — of the next four paragraphs on the Web page. 

4 Make sure to save your work and close the page. 

This Web page should look better now than when you started. We’ll 
finish it in the next chapter by making the map clickable. In the next 
section you’ll do some formatting with a different Web page tool — 
the table. 

Creating the Package Tours table 
A prototype version of the Custom Tours Web page already exists but you 
decide to refine it. It needs to be easier for the busy professionals this Web 
site targets to quickly scan the text and find the information they need. 

To make the different kinds of information stand out, you are going to split 
up the paragraphs of text and put them into a table. Each tour occupies a 
single row in the table, with different kinds of information in each column. 
Starting with the first column on the left, they are going to contain:
■ Tour titles
■ Length of the tours
■ Prices of the tours 
■ Tour descriptions

Bold run-in title
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Some of the table features you want to use in the Package Tours table are 
labelled in the following illustration:

Graphic in table cell 
 

Background color 
in a table cell

A table cell that spans four columns

A cell that spans two rows A cell that spans
two rows 
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Adding the table

The first step (after opening the Web page you’re going to reformat) is to 
generate the new table into which you’re moving the tour descriptions. 

To begin working on the package tours table: 

1 Open the file Tours.html, from the Tour Local Site window. 

The Web page displays as shown in this picture:

2 Create a blank line after the first paragraph of text on the Web 
page. 

3 Choose the menu item Insert > Table > Table. 

4 In the Table Settings dialog box, set the Number of rows to 4 and 
the number of columns to 4.

5 In the same dialog box, set the Table Dimensions > Width by 
typing 500 in the Width box and using the drop-down menu to 
change the setting to pixels, to a static 500 pixels. This makes the 
table stay the same width as the title graphic, despite the width of 
the Web page display. 

Place insertion 
point here
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Click OK and a new table with 4 rows and 4 columns displays, as 
shown in the following picture: 

6 If you need to adjust the table for any reason, click on the table 
and drag any of the handles. 

Widening the top cell of the table 

You’re going to reuse the graphic for “upcoming Isle de Cafe tour 
packages” as the title for the table. Since this graphic is as wide as the Web 
page, a table cell in the top row needs to span the entire table. In the 
following steps you are going to widen the top table cell so it can accept 
the title banner. 

To make the top cell span all four columns: 

1 Place the insertion point in the top left table cell. 

2 Choose Edit > Properties > Table Properties. 

3  When the Table Properties dialog box displays, click on the Cells 
tab. 

Handle
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The settings affecting table cells display, as shown in this picture:

4 In the Cell Size group, change Span across columns to 4. 

As shown in the following picture, the top row of cells becomes one 
wide cell:

5 Close the dialog box and save your changes. 

Click Cells tab
to see these settings

Number of rows or
columns that cell spans

Cell spans
four columns
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Inserting the graphic and changing the cell color

The title can be moved into the top cell of the table by simply dragging it 
from its old location on the Web page to its new place in the table. 
However, depending on how wide your table becomes when as a Web 
page becomes wider, the Custom Tours graphic is smaller than the table 
cell so you need to hide its boundary by adjusting the color of the cell to 
match the graphic.

To place the graphic and adjust the cell color to match:

1 Drag and drop the title title “upcoming Isle de Cafe package tours” 
into the top cell, as shown in this illustration::

2 While keeping the insertion point in the top cell, choose Edit > 
Properties > Table Properties. 

Drag and drop the title
from the Web page 
into the table cell
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3  When the Table Properties dialog box displays, click on the Cells 
tab. The dialog box displays as shown:

4 Set the Cell background color drop-down color well to match the 
yellow graphic and Visual Page instantly applies the color to the 
cell’s background: 

5 Make sure to close the dialog box and save your changes.

Graphic

Original cell
background color

Set cell background
color here

New cell 
background color 

New cell background
color setting
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Adding the tour text to the table 

While you could cut and paste, or even retype the tour information, the 
easiest way to move the descriptions of the Isle de Cafe tours into the 
table, is to drag the text from the Web page and drop it into the table. 

To move the Tour information into the table:

1 Select the first tour title, then drag it to the table and drop it into 
the column cell at the top left of the first empty row. 

2 Repeat step 1 for the other two tour titles, moving down a row 
each time.

3 Select and drag the number of days from the second and third 
paragraphs  (12 days and 14 days) and drop that text into the 
second column of the second row and third rows, respectively. Do 
not drag the number of days from the last paragraph yet. 

4 Select and drag the price from the second and third paragraphs 
into the third column of the second row ($4500) and third row 
($3500), respectively. Leave the price and duration for the third 
paragraph for now.

5 Select and drag the descriptions for each of the tours into the 
appropriate fourth column cell. 

When you finish, your table should look like this:
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Creating space in the table for options 

There are two options for length and price of the Active Adults Tour, in 
paragraph four, which are not yet in the table. The table needs to be 
adjusted for these because they share the same description and tour title. 
To adjust the table, you are going to make the title and description cells 
span two rows, after you first add another row. 

To adjust the table cells for the Active Adults Tour options:

1 Place the insertion point in Active Adults Tour title cell. 

2 To add the new row, choose Insert > Table > Row. If there is no 
insertion point in the table, this menu item is dimmed. 

An empty row is added at the bottom of the table, making the table 
appear as shown here: 

3 Move the insertion point to the Active Adults Tour cell.

4 Choose Edit > Properties > Table Properties.

5 In the Table Properties dialog box, click the Cells tab.

The view switches to show the Cells settings. 

New row
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6 In the cell size group of the Cells Table Properties, set the cell size 
to span down two rows, as shown:

7 With the dialog box still open, place the insertion point into the 
fourth column, with the Active Adults tour description.

8 Repeat steps 6 - 7. 

When done, your table looks like this:

Set the cell to 
span 2 rows
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9 Close the Table Properties dialog box. 

10 Now you can drag the remaining tour information into the cells:
■ In the second column drag in 7 days and 14 days, to the top 

and bottom cells, respectively. 
■ In the third column $3500 and $6500 go in the top and bottom 

cells, respectively.

Finishing the Custom Tours table

Since all the information is in the table now, you want to adjust the table 
so the information presents itself attractively. The duration and cost 
columns are way too big for the size of the information they contain. You 
decide to adjust them to fit the information.

To adjust column and row sizes for the Upcoming Tours table:

1 Make the table active by clicking anywhere inside it. 

In the active state, the table is outlined with a thick grey border and 
dark colored handles. This is the state that allows you to modify the 
table in some way. You can see the active state appearance of a table 
below:

Tip: You cannot delete a table unless it is selected. To select a 
table, click directly on its border and it will show a dark black 
outline. 

Active table 
appearance
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2 Move the cursor over a vertical or horizontal divider.

As it passes over divider lines, the cursor changes appearance to 
indicate that you can move the vertical and horizontal borders. 

3 To adjust the row or column sizes place your cursor over a 
dividing line and drag the divider to the desired size. 

4 Repeat step 3 as needed until the table looks good. 

Centering text in the middle columns

You decide that one last formatting detail needs to be done to make the 
table look just right. And, it probably is true that the text in the length and 
cost columns will look better if it is centered. In Visual Page you can select 
the columns all at once and center everything in an easy two-step 
procedure. 

To center the text in the prices and duration columns:

1 Select all the text in columns 2 and 3 of the travel table by clicking 
in the upper left corner and dragging diagonally through the 
columns.

The selected cells are shown in the following picture:

2 Select Format > Paragraph Alignment > Center. 

Click and drag 
across the cells
to select 
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Visual Page simultaneously centers all the text in both columns so 
that the table now looks like this:

3 Finish the Custom Tours page by deleting everything left from the 
former paragraphs below the table. 

Your finished Custom Tours page now looks, as follows:

Congratulations! You finished another of the Amazing Adventures’ 
Web site pages. Let’s move now to the Reply Web page. As you close 
this Web page, be sure to save the changes you made.
4-27



Chapter 4: Building the Amazing Adventure Web pages
Creating the reply form
The travel agency wants to make it easy for new clients to send them 
requests for information from the Amazing Adventures Web site. To fulfill 
this requirement, you are going to build a Web page containing a reply 
form that has user interface elements for a customer to fill in. The form will 
provide places for a customer to indicate the kinds of travel tours in which 
they’re interested, add personal information, and enter their comments. It 
will also add a button that they can use to send the form via e-mail to 
Amazing Adventures Travel. 

While creating the reply form you will be:
■ Using the form palette 
■ Inserting groups of radio buttons
■ Adding text input fields
■ Placing Send and Reset buttons

The Web page Reply.html has been set up for you to use in the 
following procedures. It contains the e-mail title header and labels for 
fields and buttons you’ll add. The different labels for the user 
interface elements you’ll add in these steps, are shown in the 
following illustration:

Text 
box 
labels 

Radio 
button 
labels 

Text area
labels 
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Adding text boxes to the reply form

Using the Form Tools toolbar is the easiest way to add the buttons, menus, 
and text input fields to your Web page. You’ll use this toolbar to add all the 
interface elements you need for the E-mail Reply form Web page. In this 
first set of steps you’ll open the Form Tools toolbar and use it to add fields 
for entering text from the keyboard. 

To quickly add the text boxes after their labels:

1 Open the file named: Reply.html. It’s in the Tour folder at the 
root level. 

2 Choose View > Toolbars and make sure that Form Tools is 
checked. 

The Form Tools are the part of the toolbar that looks like the 
following illustration:

3 Place the insertion point on the blank line after a label. (The first 
label is Name the last is E-mail.) 

4 Click the Text Box button on the Forms Palette. 

A text box displays. 

5 Repeat steps 3-4 for each of the labels for Name through E-mail.

Reset Button

Submit Button

List Box

Drop-down 

Text Area

Text Box

Radio Button

Check Box
list
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When finished, your screen appears as follows: 

6 Resize the fields to the width of the title banner by:
■ Clicking on the input field border to select it
■ Dragging a handle on the right side of the box

Adding the radio buttons 

Since you want the customer to choose between three types of tours, you 
are going to add a group of three radio buttons, which they can use to 
indicate their choice. 

To add the radio buttons for indicating tour choices:

1 Scroll down past the text boxes you added to Reply.html 
previously, and place the insertion point on the same line as the 
word Custom, before the initial C.
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2 Click the Radio Button on the Form Tools toolbar. 

A radio button displays on the Web page next to the label, like this:

3 Select the radio button by clicking on it once. 

Its selected appearance is shown in the following picture: 

4 With the button selected, choose Copy from the Edit menu.

5 Place the insertion point before the initial P of Package.

6 Choose Paste from the Edit menu.

The copied radio button displays. When you use a copy of one radio 
button to generate the radio buttons, Visual Page understands that 
this is a set of radio buttons which should function as a group. If you 
use this approach, your group of radio buttons will work in Preview 
mode as they would on a finished Web page.

7 Repeat steps 5-6 with the last label, Both. 

8 Choose View > Preview to switch to Preview mode. 

9 Click on any radio button in the group and you see that only one 
is selected at a time, just as you would expect. 

10 Choose View > Page to switch back to Edit mode. 

Selected radio button
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Adding customer comment areas 

In order to find out what your customers want, you give them some extra 
space where they can type as much as they want. You do this with a 
scrolling text area. In the following steps you place a scrolling text area 
after each of the questions at the bottom of the Web page. 

To insert the scrolling text areas:

1 You should already have the file named Reply.html open and 
the Form Tools toolbar visible. 

2 Place the insertion point on the blank line, after the question, 
“How did you find us?”

3 On the Form Tools toolbar, click the Text Area button.

A text area displays on your form. It’s shown in the following 
illustration in an active state:

4 Resize the text area to the width of the text boxes at the top of the 
form, by dragging the appropriate handle.

5 Repeat steps 1-4 to add another scrolling text area after the 
question, “Do you have any other comments?” 

Handle

Handle

Handle
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Adding the Submit and Clear buttons to the e-mail form

To finish the e-mail Web page form, you are going to add two buttons at 
the bottom of the form which are labelled:
■ Submit; this automatically sends the e-mail when clicked 
■ Clear; this button conveniently clears all the user input

To add the Submit and Clear buttons: 

1 Place the insertion point on a blank line at the bottom of the Web 
page. 

2 If the insertion point is not in the center of the line, choose Align 
Center from the Format menu.

The insertion point displays in the center of the line. 

3 Click the Submit button icon on the Forms Palette.

A Submit button displays at the center.˙

4 With your insertion point placed after the Submit button, choose 
Spacer from the Insert menu. 

The Spacer Properties dialog box displays, as shown:

Spacers create blank space and so are usually invisible. In this case 
the spacer will create a space between the Submit and Clear buttons. 

5 Leave the Spacer Properties as they are and click OK. 

The spacer is inserted but all you see is the cursor move the number 
of pixels specified in the dialog box. The default spacer settings 
create 30 pixels of horizontal whitespace. This is fine for our 
purposes. 

Spacers create a rectangular
area of blank space
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You can see the spacer only if you select it, as it is shown in the 
following illustration:

6 If it’s not already there, place the insertion point after the 
spacer.

7 Click the Reset button icon on the Form Tools toolbar.

A Reset button displays next to the now invisible spacer, so that this 
portion of the Web page now looks like this:

8 Double-click on the word Reset on the Reset button.

When selected, it looks like this

9 Type Clear. 

This changes the text of the button from Reset to Clear. 

Save your changes and this Web page is finished! In fact, the whole 
Amazing Adventures Web site is well on its way to being finished. 
Before going on, make sure to close this Web page. 

Note: Forms, like the e-mail form you just created, require code to 
communicate with your Web server before they can pass data from users 
— like names and e-mail addresses — back to you. See the Visual Page 
User’s Guide for more information about CGI scripts. 

Highlighted spacer
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Summary
Summary
In this chapter you worked on four Web pages for the Amazing Adventures 
Travel Web site. Along the way, you were introduced to many Web page 
building concepts. 

In creating the Customer Comments Web page you learned to:
■ Create a new, blank Web page 
■ Import text (the Customer Comments) from an existing text file
■ Add a graphic (the Customer Comments title banner) to the Web 

page

While you were creating the island map Web page you learned to:
■ Add graphics (island photos) to a Web page
■ Flow text around graphics (the photos) 
■ Resize graphics (the photos) 
■ Make the section titles bold

While formatting the custom tours table you learned to:
■ Create a new table
■ Span a cell across the top of the table
■ Change cell color 
■ Drag and drop text into the table 
■ Adjust the size of columns and rows
■ Add a row
■ Span a cell across rows
■ Simultaneously center the text in all cells of two columns

While working on the interactive e-mail reply form, you learned to:
■ Add single-line text entry boxes, as well as scrolling text areas
■ Use radio buttons
■ Position and add Submit and Clear buttons to a form
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What’s next
You’re now over half-way finished with the Visual Page tour and have 
done most of the basic building of the site. Essentially, what’s left is the 
creation of the home page, linking together the parts of the site, and 
adding movement to the opening Web page. You’ll accomplish these 
things and finish up the Amazing Adventures Web site in “Adding life to 
the Amazing Adventures Web site” on page 5-1.
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Adding life to the Amazing 
Adventures Web site

One of the best features of the World Wide Web and Web pages in general, 
is the support they provide for animated and interactive elements. To 
entice your visitors you’ll add the following interactive elements to 
different Amazing Adventures Web site Web pages: 
■ An animated airplane and pilot
■ A slide show controller which visitors click on to change photos 
■ Locations on an island map which bring you more information
■ Linked icons which which visitors click on to display Web pages 

In this chapter, you’ll also create the Home page and use it to tie together 
all the Web pages in the Web site. This is done by linking the Home page 
Table of Content icons to the other Web pages you worked on in “Building 
the Amazing Adventure Web pages” on page 4-1. By the end of this 
chapter you will have an entire working Web site.
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Creating movement on the Home page
The opening Web page is the first screen visitors see when they arrive at 
the Amazing Adventure Web site. You know that to make a good 
impression, it needs to be attractive, exciting, and engaging.You want to 
draw people into Amazing Adventures, so they will spend some time 
exploring the tour package information the Web site contains.

You already have some colorful, custom-designed fonts for the Amazing 
Adventures Travel logo and an interesting looking Isle de Cafe description 
in place on the opening Web page that help make it attractive. But you still 
need some movement on the Web page and have an interactive slide-show 
and an animation you are going to add. 

The following illustration shows the images, animations, and interactive 
slide show which you plan to incorporate as part of the opening view of 
the Web site:

TOC graphic links
Applet animation

logo graphic
Custom-designed

Applet slide show
with clicker control

Graphic

Graphic

Graphic
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Adding the plane animation

You are about to add the animated plane and pilot to the Isle de Cafe 
Home page. Since this animation happens to be in the form of a Java 
applet, you’ll be adding a Java applet to your Web page here. 

As Java applets are really mini-applications for Web pages, you should 
know that before it’s ready for a Web page, a Java applet must be coded, 
tested, debugged, and compiled in a development environment like 
Symantec’s Visual Cafe. If you own Visual Cafe, you can build the applets 
that come with this Tour by working through the Getting Started with 
Visual Cafe Tour. 

The applet you’re going to use has already gone through the process of 
being coded, tested, debugged, and compiled. You will be doing the fun 
part, which is adding the applet to the Web page and previewing it to see 
it work. 

To insert the plane applet:

1 Open a Local Site window at the root level of the Tour folder. 

2 From the Tour Local Site window, double-click on Opener.html 
to open it. 

3 Drag plane.class (the applet) to the line after the small 
subheading graphic: “Custom and package tours for individuals 
and bussiness.” 
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An applet placeholder displays on the Web page. 

4 Double-click on the applet placeholder. 

The Java Applet Properties dialog box displays. 

5 In the Java Applet Properties dialog box, set the dimensions of the 
applet to: Width 500 and Height 80. It’s important to get the size 
right on this applet or the graphic won’t display when you try to 
view it in Preview mode or in a Browser. 

6 Click OK to close the dialog box. 

Applet 
place-
holder
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After the placeholder’s size is adjusted, it displays as shown in the 
following picture:

7 You can see the plane applet come to life in your Web page 
without leaving the Visual Page application — just choose View > 
Preview. If you didn’t install the Java folder when you installed 
Visual Page, choose View > Preview in Browser to see the applet 
running in whatever Java-enabled browser you have installed on 
your computer. 

The Java coffee cup changes to the Amazing Adventures mascot 
shown below:

8 Switch back to Edit mode by choosing View > Page.

New size 
of applet 
placeholder 
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Adding the interactive slide show

Now you are going to add the other interactive piece of the opening Web 
page: the slide show. When a visitor clicks on the controller arrow, the Isle 
de Cafe photo switches to a new picture and its corresponding text:

Like the animation applet, this applet has already been compiled and 
tested for you. 

To insert the slide show applet:

1 Drag SlideShow.class from the Local Site window and drop it 
on a line after the “Isle de Cafe” paragraph. 

A second applet placeholder displays. 

2 Open the Java Applet Properties dialog box by double-clicking on 
the SlideShow.class placeholder. 

3 Set the dimensions of the applet to: Width 525 and Height 350. 

This is so you’ll be able to see the whole applet. 

4 Click OK to close the dialog box.

5 If you installed the Java folder with the application, you can 
choose View > Preview and see the slide show applet running in 
your Web page.

6 If you didn’t install the Java folder, choose View > Preview in 
Browser. The Web page opens in your Java-enabled browser so 
you can try out the slide show. 

Click on the 
controller to
change 
pictures
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7 After you have satisfied yourself that the slide show applet works 
as expected, go back to the Visual Page Edit mode. (Choose the 
menu item View > Page.)

8 Save your changes and close this Web page.

The opening Web page is finished! In the next section you are going to go 
back to the Island Map Web page and finish it by making the map 
locations clickable. 

Making the map clickable 
The Island Map Web page is fairly long because there are four towns on 
the island which you want to describe in detail. To make the length of the 
Web page easier to navigate, you decide to make the locations on the map 
respond to a mouse click by automatically scrolling the Web page to the 
location’s description. 

While authoring this Web page, you will learn to:
■ Insert anchors — you use these to mark the Web page at the start 

of the description for each town
■ Set up the island map to function as an image map — image map 

is the technical term for a graphic that has clickable regions which 
link to more information 

■ Outline the clickable areas on the island map
■ Link the locations on the map to the anchors in the text

Marking the descriptions with anchors

Before you can link the map to the title for each town, you must first 
identify the matching titles with HTML markers known as anchors. 

To mark each description’s title with an anchor:

1 Open the Map.html Web page.

2 Place your insertion point before the Bungbusi header. 

3 Choose Anchor from the Insert menu.

4 In the Anchor Properties dialog box, type Bungbusi.

When you close the dialog box, an anchor symbol displays next to 
the title. You can see the anchor marker when viewing the Web page 
in editing mode only. The marker is invisible when the Web page 
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displays in a Web browser. Here’s how an anchor appears while 
you’re editing:

5 Repeat steps 2-4 to create anchors for the other headings. Make 
sure you substitute the names Venduca, Simerilia, and Moderna in 
those steps.

Setting the map to function as an image map

Now that the anchors are set in the text, you are going to outline the areas 
on the island map graphic, at the top of the Web page, which will link to 
the anchors. After you outline these, you can link them to the anchors 
marking the corresponding descriptions. 

To change the island map to function as an image map:

1 Open Map.html, if it is not already open.

2 Choose View > Toolbars > Image Tools.

The Image Tools toolbar displays. You’re going to use its tools to 
outline and link the map areas. 

3 Click on the map image, at the top of the Web page, to select it. 

Anchor
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4 Use the rectangle drawing tool to outline the locations on the map, 
as shown:

Linking the towns to their descriptions

Now that you’ve set up the map graphic and marked the descriptions in 
the text with anchors, it’s time to link the two. 

To link the towns to the corresponding anchors:

1 Double-click the Bungbusi rectangle to open the Link dialog box. 

2 Click on the Anchor drop-down arrow and select Bungbusi, as 
shown in the following illustration. 

3 Click OK to close the dialog box. 

Use rectangle 

Outlined locations
are ready to link

tool to outline for links
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Notice that the URL now displays in the selection rectangle, after you 
complete the process: 

4 Repeat steps 1-3 with the anchors and selection rectangles for: 
Venduca, Simerilia, and Moderna.

5 After you save the changes, you can try out the links in Preview 
mode to make sure they work correctly. 

Once you’re satisfied that the map links work as planned, you’re 
done. Another Web page is finished! Save your changes and close this 
Web page to get ready for the next step. In the following section, you 
are going to create the Home page and link the other Web pages, 
which you already finished, to the Table of Contents.
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Creating the Home page
While constructing the Amazing Adventures Home page you are going to:
■ Create a new Web page with two frames
■ Set each frame to display a different Web page
■ Link the TOC icons to the Web pages you finished earlier

Opening the new page — with frames

Back in the planning stages of this project, you decided to divide the 
Amazing Adventure Home page into two or more framed areas. The frame 
on the left of the Home page is to always display the Table of Contents 
(TOC) icons. Those icons will link to the Web sites’ other Web pages so 
that when clicked, they will display in the Home page frame on the right. 

Using this scheme, the TOC icons become a kind of landmark that is 
always visible and at the left side of the Web page. If your customers want 
to see another of the Amazing Adventure Web pages, they just click on any 
of the TOC icons and the Web page linked to that icon will display in the 
content frame on the right side of the Home page. The general logic of 
how the Home page works, is shown in the following illustration: 

First click here

displays in

Map.html

TOC frame Content frame

Web page 

content frame
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The following steps show you how to create a Web page with the two 
frames required by this design. 

To create the Amazing Adventures Home page:

1 Select New Frame Set from the File menu. 

A new Web page displays. It is divided vertically into two 
independent Web page display areas — known as frames. The Web 
page which contains the frames is known as a frame set. The new 
frame layout and its frames are shown in this picture:

2 Choose Save Frame Set As from the File menu, to save this Web 
page at the root level of the Tour folder as: Home.html. 

will display 
HomeTOC.html

will display 
other Web pages

Right frame 

Left frame

Frame set 
5-12



Creating the Home page
Setting up the Home page Table of Contents 

Keeping in mind that each of the Home page frames can display a Web 
page, you are going to assign an already existing HTML source file to each 
frame. Each frame will then display a different Web page. 

Rather than putting the TOC icons directly into the frame on the left, you 
are going to set that frame to display a ready-to-use Web page, 
HomeTOC.html. This Web page is at the root level of the Tour folder.

To assign a Web page to display in the TOC frame:

1 The Home page (Home.html) should still be open. Select the 
TOC frame (on the left) of the Home page by clicking anywhere in 
it.

A heavy selection border outlines the left frame of the Home page.

2 From the Frame menu, choose Set Frame Source.

An open file dialog box displays. 

3 Navigate to HomeTOC.html (it’s at the root level of the Visual 
Page Tour folder) and double-click to open it. 

When you open HomeTOC.html, it displays in the selected frame. 

4 Resize the frames so your Web page looks proportional to the one 
shown in the following picture: 

displays in
Web page 

TOC frame 

HomeTOC.html
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Setting up the opening page display

Now that the Table of Contents is displayed in the left frame, you’re going 
to set the frame at the right of the Home page to display the Amazing 
Adventures opening Web page (Opener.html.) 

To assign the opening Web page to display in the content frame:

1 Select the content display frame (on the right) of the Home page 
by clicking anywhere in it.

A heavy selection border outlines the frame on the right.

2 From the Frame menu, choose Set Frame Source.

An file dialog box displays. 

3 Using the dialog box, navigate to Opener.html (it’s at the root 
level of the Visual Page Tour folder) and double-click to open it. 

When you open the Web page (Opener.html) it displays in the 
selected frame. If you switch to Preview mode, your Web page will 
look like the Home.html Web page shown at the left of the following 
illustration: 

displays in
Web page 

right frame 

Opener.html
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Creating a working Table of Contents 
You decided at the beginning of this project that the Table of Contents 
would always display in the left frame of the Home page and all its linked 
Web pages would display in the neighboring frame. To make this work 
you must:
■ Link the Table of Contents icons
■ Set linked Web pages to display in the Home page’s right frame 

Linking Web pages to the Table of Content icons

You’ve planned it so that one Web page corresponds to each of the TOC 
icons. After you finish linking these icons to the Web pages, you can use 
the Visual Page Preview mode to test the links.

Note: The HTML files you need when linking the icons are all at the root 
level of the Tour folder. 

To link the TOC icons:

1 Open the Local Site window and position it so it’s visible at the 
side of the Home page. (The Home.html Web page should 
already be open. If not, open it.)

2 Click on a Home page TOC icon (in the left frame) to select it. 

It displays with a heavy black border. 

3 Drag the Web page file corresponding to the icon (shown in the 
second column of the following table) from the Local Site window 
and drop it on the selected TOC icon.

Link this Icon To this Web page

Home Page and Slide Show Opener.html

Island Map and Information Map.html

Client Comments Talk.html

Custom and Package Tours Tours.html

E-mail Request Form Reply.html
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4 Repeat steps 2-3 until all the icons are linked. 

5 Make sure to save your changes. 

6 Switch to Preview mode by choosing Preview View > Preview.

7 In Preview mode, click once on any linked icon. 

Notice that when the Web page displays, it displays in a separate Web 
page window. That’s because all links in a Web page default to 
displaying their linked Web pages in separate windows. In the next 
section, you’ll redirect the Home page’s display of linked Web pages 
to the designated content frame. 

8 Except for the Home page, close all the other open Web pages. 

9 Choose View > Page to switch back to Edit mode. 

Setting the display destination of the TOC links

You need to set the Home page to display its linked Amazing Adventures 
Web pages in the content frame on the right of the Home page. You 
achieve this by identifying the frame on the right side of the Home page as 
the “display target” of the Home page. With this setting, any Web page 
links on the Home page are displayed in the content frame rather than in a 
new window, which is the default case. 

To set a display target for the TOC icons:

1 The Home.html file should still be open. 

2 Click once in a blank area of the TOC frame to select it. (Click 
outside the icons or you’ll select an icon instead.) 

The TOC frame is outlined by a heavy black border.

3 Choose Edit > Properties > Page. 
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The Page Properties dialog box displays. The settings you will change 
are labelled in the illustration shown below:

4 In the Page Properties dialog box, click on Select Base Target.

The Base Target dialog box displays, with a thumbnail sketch of the 
Home page in it. (See the next illustration.)

5 In the Base Target dialog box, click on the frame on the right of 
the thumbnail sketch to select it. 

Set Title

Click here 
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The new display target for the linked Web pages, appears as shown 
in the following illustration: 

6 Click OK to close the Base Target dialog box.

The Base Target dialog box closes but the Page Properties dialog box 
is still open. 

7 Set the Title in the Page Properties dialog box to Home.

This title shows in the title bar of the Web page when it is displayed 
in a Web page browser. 

8 Click OK to close the Page Properties dialog box. 

The settings for the Home page are finished. 

Testing the Home page Table of Contents

You now need to test the Table of Contents’ links to see if everything 
works to your satisfaction. The Visual Page Preview mode enables you to 
do this quickly. 

Previewing links in the Home page:

1 With the Home page still open, switch to Preview mode by 
choosing View > Preview.

2 Move the pointer over the Island Map and Information icon. 

The pointer turns into a hand icon.

3 Click on the icon.

New display target
for linked Web pages
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The Web page should display in the frame on the right side of the 
Home page. If it does not, recheck the steps in the previous set of 
procedures.

4 Repeat steps 2-3 for all the icons in the Home page Table of 
Contents frame. 

5 Save your changes. 

6 When you display the Custom and Package Tours Web page, try 
clicking on the “send us e-mail” link. If the display target was set 
correctly in the Document Settings for the Home page, this linked 
Web page will also display in the content frame on the right of the 
Home page. 

Now that everything works, take a little time to congratulate yourself. 
You’ve just finished building a working Web site! This local Web site 
is now ready to be published to an Internet server. 

Publishing your Web site
Now that you’ve created an entire Web site you are ready to place it up on 
the Web. Visual Page is designed to complement and expedite this process 
with its built-in FTP network access tool. 

When you publish a Web site, Visual Page uses a network protocol (a set 
of predefined commands) to place the files on a Web server — a 
computer that’s dedicated to storing and sending out Web-based files. The 
most common protocol used for transferring files to a Web server is the 
File Transfer Protocol (FTP.) 

Visual Page lets you use FTP in the form of a window that enables you to 
upload and download your local Web site from your system to a Web 
server. From within its FTP window, Visual Page provides extensive FTP 
support, including the ability to upload, download, rename, and delete 
server-based files. Since the procedure for connecting to an Internet server 
is slightly different for each connection, no steps are provided here. For 
more information see the Visual Page User’s Guide. 
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Chapter 5: Adding life to the Amazing Adventures Web site
Summary
Your home page and your version of the Amazing Adventures Web site is 
done! In this chapter you set the interactive elements to work in the Web 
site by:
■ Adding an animation
■ Placing an interactive slide show applet
■ Creating a home page with frames
■ Setting each frame of the home page to display a different Web 

page 
■ Linking Table of Contents icons to corresponding Web pages
■ Setting the target for the display of linked Web pages to the 

content frame on the right of the home page

Now that you’ve had the chance to see how easy it is to build Web pages 
and link them together as Web sites you can go ahead an put your own 
ideas into action. A good way to start is to modify or use pieces of the 
Visual Page templates, which are provided with the application. As you 
work, you should consult the Visual Page User’s Guide for more 
information. We hope you enjoyed the process and will use Visual Page to 
build many excellent Web pages. 
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C H A P T E R 6
Support Information

This chapter describes where to get more information on Visual Page. It 
has the following sections:
■ Where to get information
■ Product updates
■ Symantec service and support solutions 
■ Registering your Symantec product
■ Technical support
■ Electronic support 
■ Customer service
■ Service and support headquarters
■ Worldwide service and support

Note: The information in this chapter, including URLs, is subject to change.
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Where to get information
Visual Page includes the following documentation:

Product updates
Check the Symantec Web site (www.symantec.com/) for updates to 
Visual Page. After you have registered your copy of Visual Page, you can 
use your login name and password to download patches and updates to 
your current version. If you bought your product in a box, the user ID and 
password are included with your package. If you bought your product 
online, the user ID and password were displayed to you on the screen.

Symantec service and support solutions 
Symantec is committed to excellent service worldwide. Our goal is to 
provide you with professional assistance in the use of our software, 
wherever you are located.

Technical Support and Customer Service solutions vary by country. If you 
are outside the United States or Canada, please refer to the Worldwide 
Service and Support section at the end of this chapter.

Registering your Symantec product
If you have ordered the product online, you are automatically registered 
through Customer Service. In addition, you can use the toll-free fax 
number listed below to register your product, or register on the Customer 
Service Home Page under Service and Support at www.symantec.com.

If your address changes, you can mail or fax your new address to Customer 
Service. Please send it to the attention of the Registration Department.

Title To find it...

Visual Page Help Choose Help from the Help menu.

Visual Page User Guide Included in the Visual Page box. 
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Technical support
Symantec Corporation
Attn: Registration Dept.
175 W. Broadway
Eugene, OR 97401

(800) 800-1438 Fax

You can also change your address on the Customer Service Home Page 
under Service and Support at www.symantec.com.

Technical support
Symantec’s Technical Support department offers expanded support options 
designed for your individual needs and to help you get the most out of 
your software investment.

The phone numbers listed in the “Service and support headquarters” 
section are for support in North America. If you are outside the United 
States or Canada, please call the local Symantec office or distributor in your 
area, or refer to the information provided at the end of this chapter.

Symantec now offers different types of technical support services for you 
to choose from, which are described below. You are given StandardCare 
Support by purchasing the product and then can choose from Symantec’s 
PriorityCare and PremiumCare services to extend your level of support.

For the most current information on Symantec Support Solutions, please 
call our automated fax retrieval service, located in the United States, at 
(800) 554-4403 or (541) 984-2490, and request document 070. Alternatively, 
visit Symantec on the World Wide Web at www.symantec.com.

StandardCare support

All registered users of Symantec products are entitled to these services at 
no charge:
■ Unlimited calls for 90 days (from the date of the first call) for 

installation assistance, configuration, and general usage questions. 
The phone number is (541) 465-8470.

■ Unlimited technical assistance through America Online. This forum 
offers electronic access to our technical support staff, libraries of 
sample files, technical notes, and bulletins. You will also find a rich 
interaction and information exchange with other users of Symantec 
software.
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Chapter 6: Support Information
■ Unlimited use of the Symantec Discussion Groups available from 
the Service and Support section on www.symantec.com. These 
forums offer electronic access to our professional technical support 
staff, the Symantec knowledge base, FAQs, and announcements. 
The news server is at service.symantec.com.

■ Unlimited access to company information through the Internet. 
With a Web browser such as Netscape, you get the latest company 
news by entering the URL for Symantec’s home page: 
www.symantec.com. 

■ The Web site include links to our anonymous FTP site, where you 
can download the latest software patches and drivers for Symantec 
products. You can also FTP directly to the site by entering: 
ftp.symantec.com. 

■ Unlimited use of Symantec’s automated fax retrieval system for 
instant printouts of technical notes, bulletins, product literature, 
and general information by fax.

■ StandardCare Support is available Monday through Friday, 7:00 
a.m. to 4:00 p.m. Pacific Time.

For your first 90 days of free technical support, please refer to the 
StandardCare Support (541) phone number in the “Service and support 
headquarters” section.

PriorityCare support

All registered users of Symantec products are entitled to these services on a 
“pay-as-you-go” basis:
■ The PriorityCare 800-number is charged to your VISA, MasterCard, 

or American Express on a per incident basis. 
■ The PriorityCare 900-number is charged to your telephone bill on 

a per minute basis. (As of this writing, the charge is $2 per minute, 
and an equivalent 900-number service is not available outside the 
United States.)

■ Average hold time will be kept to a minimum.
■ PriorityCare Support is available Monday through Friday, 6:00 a.m. 

to 5:00 p.m. Pacific Time.

To use the PriorityCare 800- and 900-number services, please refer to those 
numbers in the “Service and support headquarters” section.
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Technical support
PremiumCare support

All registered users of Symantec products are entitled to these services on 
an annual subscription basis:

PremiumCare Gold support
■ Support for one year for a set number of incidents, with an option 

to add more incidents.
■ Priority support on a a toll-free 800 line.
■ Average hold time will be kept to a minimum.
■ Electronic mail support is provided with a 24-hour response time 

on working days. The PremiumCare Gold Support is available for 
Visual Page for Windows owners at 
support_javawin@symantec.com and for Visual Page for Macintosh 
owners at support@devtools.symantec.com. Please include your 
subscription ID with any e-mail. 

■ PremiumCare Gold Support is available Monday through Friday, 
6:00 a.m. to 5:00 p.m. Pacific Time.

PremiumCare Platinum support
■ Unlimited calls on a toll-free 800 line.
■ Average hold time will be kept to a minimum.
■ A Support Center Manual with troubleshooting, installation, 

configuration, and usage information.
■ Quarterly updates of technical notes and bulletins.
■ Instant access to senior support staff.
■ Automatic updates of inline software revisions. (Inline software 

revisions do not include version upgrades.)
■ After hours and weekend support is also available to PremiumCare 

Platinum customers for an additional fee.
■ PremiumCare Platinum Support is charged on an annual 

subscription basis per product family. The annual fee is for two 
subscribers; other subscribers can be added on a per person basis.

■ PremiumCare Platinum Support is available Monday through 
Friday, 6:00 a.m. to 5:00 p.m. Pacific Time.

■ Electronic support for Visual Page for Windows owners at 
support_javawin@symantec.com and for Visual Page for Macintosh 
owners at support@devtools.symantec.com. 
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To order PremiumCare Gold or Platinum support, please contact Customer 
Service or your Symantec sales representative. 

Electronic support
Technical information is available electronically 24 hours a day. Symantec 
maintains the Symantec forums on America Online.

America Online

To access the Symantec bulletin board on America Online, type keyword:

SYMANTEC

For additional information, or to subscribe in the United States and Canada, 
please call America Online at (800) 227-6364. Check with America Online 
for data communications settings.

Symantec discussion groups

Use your Web browser to go to http://www.symantec.com and go to 
the Service and Support section. Here you can review the Frequently 
Asked Questions, search the Symantec Knowledge Base for known 
solutions to problems previously encountered, or post your own query to a 
support newsgroup. 

Symantec representatives are ready to answer your questions via our 
support discussion groups. All messages posted will receive a response 
from a Symantec representative within 48 hours. The discussion groups are 
similar to electronic bulletin boards where you post a message and then 
return later to find an answer. These support forums are in Usenet 
newsgroup (Internet news) format and require that you have a newsreader 
available.

You can FTP directly to this site to download technical notes and software 
patches at: ftp.symantec.com. You can also use the news server, 
service.symantec.com.

Automated fax retrieval system

Symantec’s automated fax retrieval system can be used 24 hours a day to 
receive product information on your fax machine. You can call from any 
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Customer service
touch tone phone to receive an index listing of both Technical Support and 
Customer Service documents available, then have any of these specific 
documents faxed to you. 

To receive technical application notes and samples of “how tos,” please 
call our Technical Support fax retrieval number, and choose Option 2.

You can receive general product information, data sheets, and product 
upgrade order forms from our Customer Service fax retrieval number.
■ Technical Support: (541) 984-2490
■ Customer Service: (800) 554-4403

In addition, you can receive a listing of Symantec offices and worldwide 
service and support partners by calling the Technical Support fax retrieval 
number, choosing Option 2, and requesting Document 1400.

Customer service
Symantec’s Customer Service department builds and maintains long-lasting 
customer relations through consistent, expert service. Our Customer 
Service department is available to help you:
■ Order an upgrade.
■ Subscribe to the technical support solution of your choice.
■ Fulfill your request for product literature or demonstration disks.
■ Find out about dealers and consultants in your area.
■ Replace missing or defective pieces (disks, manuals, and so on) 

from your package.
■ Get status on an order or a return.
■ Update your product registration with address or name changes.
■ Replace lost passwords or user IDs.

You can reach Customer Service at (800) 441-7234 or under the Service and 
Support section at www.symantec.com. For specific questions about how 
to use your Symantec software, please contact Technical Support.

Replacing a CD-ROM

If the Visual Page CD-ROM is damaged or unusable, you can obtain a 
replacement. 
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To receive a replacement or refund for a product purchased through a 
reseller, please visit or contact the authorized dealer from whom you 
purchased the product.

If you ordered the product or upgrade directly from Symantec and wish to 
receive an replacement or refund in accordance with our 60-day money 
back guarantee, please return your CD-ROM and a letter including a brief 
explanation for the return. Please send by traceable means, such as UPS or 
FEDEX, to:

Symantec Corporation
ATTN: RMA Dept.
175 West Broadway
Eugene, OR 97401

Old version support
When a new version of this software is released, registered users may 
receive upgrade information through electronic mail or the postal service. 
After the release of the new version, telephone support will be provided 
for the previous version for 6 months. Technical information for the older 
versions may still be available on the electronic services and automated fax 
retrieval system.

Discontinued product support
When Symantec announces that a product will no longer be marketed or 
sold, telephone support will be discontinued 60 days later. Support will 
only be available for discontinued products through services such as our 
automated fax retrieval system or through documentation posted on 
electronic services such as the World Wide Web, Symantec BBS, or America 
Online.

Service and support headquarters
Symantec’s service and support headquarters for North America is at the 
following location. 
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Worldwide service and support
Worldwide service and support
Symantec provides technical support and customer service worldwide. 
Services vary by country and include International Partners (IPs) who 
represent Symantec in regions where there is no Symantec office. Most IPs 
provide customer service and technical support for Symantec products in 
your local language, as close to your home or office as possible.

If your country is not listed in the International Locations section below, 
please call our Technical Support automated fax retrieval service, located in 
the United States, at (541) 984-2490, choose Option 2, and request 
Document 1400.

International locations

European headquarters
Symantec Europe Ltd.Tel. (31) (71) 535 3111
Kanaalpark 145Fax (31) (71) 535 3150
2321 JV Leiden
The Netherlands

Customer ServiceTel. (31) (71) 535 3294

Technical Support -DutchTel. (31) (71) 579 4407
French PC/MacTel. (33) (1) 41 38 69 80

Symantec Corporation
175 W. Broadway
Eugene, OR 97401

(800) 441-7234 (USA & Canada Customer Service) 
(541) 334-6054 (all other locations)
Fax (541) 984-8020

For Visual Page technical support, please call the 
following numbers:

StandardCare Support (541) 465-8470
PriorityCare 800 Support (800) 927-4014
PriorityCare 900 Support (900) 646-0004

or post a message in the Visual Page Discussion 
Group at 
http://www.symantec.com/techsupp/index.html.
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French MacTel. (33) (1) 41 38 69 81
GermanTel. (49) (211) 9917 110
EnglishTel. (44) (1628) 788 580
Other CountriesTel. (31) (71) 579 4425
Fax (31) (71) 535 3153

International BBS (up to 14.4 baud)Tel. (31) (71) 535 3169
Automated fax retrieval (24 hrs.)Tel. (31) (71) 535 3255

Asia/Pacific Rim region
Symantec Australia Pty. Ltd.Tel. (61) (2) 9850 1000
408 Victoria RoadFax (61) (2) 9850 1001
Gladesville, NSW 2111
Australia
Technical SupportTel. (61) (2) 9879 6577
Fax (61) (2) 9879 6594
BBSTel. (61) (2) 9879 6322
Automated fax retrieval (24 hrs.)Tel. (61) (2) 9817 4550

Mexico
Symantec Mexico  Tel. (52) (5) 545 1234
Rubén Dario No. 36, Piso 2, OFNA 6  Fax (52) (5) 531 2252
Colonia Chapultapec Polanco
11560 México, D.F.

Technical Support

For Technical Support call the
automated fax retrieval service,
located in the United States, at 
(541) 984-2490, and request
Document 1400.

Japan
Symantec Japan, Inc. 
Pine Bldg. 6F
3-1-2, Shibuya, Shibuya-ku
Tokyo 150 JAPAN
Phone: (81)03-3498-1118 
Fax: (81)03-3498-1124

Every effort has been made to ensure the accuracy of this information. 
However, the information contained herein is subject to change without 
notice. Symantec Corporation reserves the right for such change without 
prior notice.
6-10



Disk Exchange and/or Replacement Form
Disk Exchange and/or Replacement Form

SECTION A - FOR DISK EXCHANGE AND REPLACEMENT

Please send me: ___ 3.5" high-density disks (exchange or replacement)

Name__________________________________________________

Company Name_________________________________________

Street Address (No P.O. Boxes, Please)_____________________

City _______State _______ Zip/Postal Code _________________

Country* ______________Daytime Phone ___________________

Software Purchase Date______________

*This offer limited to U.S., Canada, and Mexico. Outside North America, 
contact your local Symantec office or distributor.

DISK EXCHANGE: Visual Page is 
available on 3.5" high-density disks. If 
your computer doesn’t have a CD-ROM, 
you may exchange the CD-ROM for 
floppy disks at no extra charge. Simply fill 
out Section A, enclose the original CD-
ROM, and mail to the address below.

DISK REPLACEMENT: After your 
60-Day Limited Warranty, if your 
disk(s) becomes unusable, fill out 
Sections A & B and return 1) this 
form, 2) your damaged disks, and 3) 
your payment (see pricing below, 
add sales tax if applicable), to the 
address below to receive 
replacement disks. DURING THE 60-
DAY LIMITED WARRANTY 
PERIOD, THIS SERVICE IS FREE. 
You must be a registered customer in 
order to receive disk replacements.
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SECTION B - FOR DISK REPLACEMENT ONLY

Briefly describe the problem:

FORM OF PAYMENT ** (Check One):

__Check (Payable to Symantec) Amount Enclosed $_________

__Visa __Mastercard __American Express 

Credit Card Number____________________ Expires _______________

Name on Card (please print) ___________________________________

Signature ____________________________________________________

**U.S. Dollars. Payment must be made in U.S. dollars drawn on a U.S. bank.

MAIL YOUR DISK EXCHANGE AND/OR DISK REPLACEMENT 
ORDER TO:

Symantec Corporation
Attention: Order Processing
175 West Broadway
Eugene, OR 97401-3003
Please allow 2-3 weeks for delivery within the U.S.

Symantec is a registered trademark and Visual Page is a trademark of Symantec Corporation.
Other brands and products are trademarks of their respective holders.
” 1997 Symantec Corporation. All rights reserved. Printed in the U.S.A.

CD Replacement Price  $ 9.95

Sales Tax (See Table) ______

Shipping & Handling $   9.95

TOTAL DUE ______

SALES TAX TABLE: AZ (5%), CA (7.25%), CO (3%), CT 
(6%), DC (5.75%), FL (6%), GA (4%),IA (5%),IL (6.25%), IN 
(5%), KS (4.9%), LA (4%), MA (5%), MD (5%), ME (6%), MI 
(6%),MN (6.5%), MO (4.225%),NC (6%), NJ (6%), NY (4%), 
OH (5%), OK (4.5%), PA (6%), SC (5%),TN (6%), TX 
(6.25%), VA (4.5%), WA (6.5%), WI (5%). 

Please add local sales tax (as well as state sales tax) in AZ, 
CA, FL, GA, MO, NY, OH, OK, SC, TN, TX, WA, WI
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anchor

A type of link, used to mark specific locations within a Web page.

applet

A Java program that is designed to run only on a Web page.

frame

The element within a frame layout that contains a HTML file.

frame set 

A type of Web page, consisting of two or more independent sections (frames) that each 
display a HTML file.

FTP

An acronym for File Transfer Protocol. The File Transfer Protocol is the common command 
set used to upload and download files from Web sites. Visual Page uses FTP extensively as 
part of its set of Web publishing features.

GIF

An acronym for Graphic Interchange Format. The Graphic Interchange Format is a common 
cross-platform, format for Web graphics. Another common WWW graphic format is the 
JPEG format.

HTML

An acronym for HyperText Markup Language. It is used to “markup” or identify which parts 
of an .html or .htm text file to display in which format. 

Internet

The largest computer network in the world. Originally designed for military use, the 
Internet expanded into academic usage, and then into the public arena.

Intranet

A subsection of the Internet, contained within a corporate network.



Glossary
image map

A graphic with linkable regions within it. There are two types of image maps: client side, 
which contain their coordinate information within the graphic file, and server side, which 
contains its coordinate information in a separate .map file on the server.

Java

An object-oriented programming language developed by Sun Microsystems. Java is device 
independent, allowing compiled Java programs and applets to run on any computer. 

JPEG

A acronym for Joint Photographic Experts Group, the creators of the JPEG file format. The 
JPEG format was developed for high-quality photographs and supports 24-bit images. 
Another common WWW graphic format is the GIF format.

link

Web page-based text or graphics that respond to a mouse click by displaying the media that 
they’re connected to, such as a Web page. 

local Web site

A collection of Web pages that are installed on your local computer.

server

A computer that is configured (via software and hardware) for the storage and handling of 
files.

target

The frame or Web page window that a linked file displays in. 

URL

An acronym for Uniform Resource Locator. A specific address used by Web browsing 
software to locate and access information on the Web.

Web browser

The local application you use to connect to a Web server. It interprets and displays HTML-
encoded documents (Web pages) graphically.

Web page

A text document which is encoded in HTML, displayed by a browser application, and 
accessible from remote sites via the Web.
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Web server

A type of server dedicated to storing, transmitting, and receiving Web pages and Web-
related files, such as GIF and JPEG graphics.

Web site

A collection of files that are linked to a central Web page, made available via the Web.

World Wide Web

The part of the Internet that contains Web pages. The World Wide Web is commonly 
referred to either by its acronym WWW, or simply as the Web. 
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	Centering text in the middle columns
	To center the text in the prices and duration colu...
	1 Select all the text in columns 2 and 3 of the tr...
	2 Select Format > Paragraph Alignment > Center.
	3 Finish the Custom Tours page by deleting everyth...



	Creating the reply form
	Adding text boxes to the reply form
	To quickly add the text boxes after their labels:
	1 Open the file named: Reply.html. It’s in the Tou...
	2 Choose View > Toolbars and make sure that Form T...
	3 Place the insertion point on the blank line afte...
	4 Click the Text Box button on the Forms Palette.
	5 Repeat steps 3-4 for each of the labels for Name...
	6 Resize the fields to the width of the title bann...


	Adding the radio buttons
	To add the radio buttons for indicating tour choic...
	1 Scroll down past the text boxes you added to Rep...
	2 Click the Radio Button on the Form Tools toolbar...
	3 Select the radio button by clicking on it once.
	4 With the button selected, choose Copy from the E...
	5 Place the insertion point before the initial P o...
	6 Choose Paste from the Edit menu.
	7 Repeat steps 5-6 with the last label, Both.
	8 Choose View > Preview to switch to Preview mode....
	9 Click on any radio button in the group and you s...
	10 Choose View > Page to switch back to Edit mode....


	Adding customer comment areas
	To insert the scrolling text areas:
	1 You should already have the file named Reply.htm...
	2 Place the insertion point on the blank line, aft...
	3 On the Form Tools toolbar, click the Text Area b...
	4 Resize the text area to the width of the text bo...
	5 Repeat steps 1-4 to add another scrolling text a...


	Adding the Submit and Clear buttons to the e-mail ...
	To add the Submit and Clear buttons:
	1 Place the insertion point on a blank line at the...
	2 If the insertion point is not in the center of t...
	3 Click the Submit button icon on the Forms Palett...
	4 With your insertion point placed after the Submi...
	5 Leave the Spacer Properties as they are and clic...
	6 If it’s not already there, place the insertion p...
	7 Click the Reset button icon on the Form Tools to...
	8 Double-click on the word Reset on the Reset butt...
	9 Type Clear.



	Summary
	What’s next

	Adding life to the Amazing Adventures Web site
	Creating movement on the Home page
	Adding the plane animation
	To insert the plane applet:
	1 Open a Local Site window at the root level of th...
	2 From the Tour Local Site window, double-click on...
	3 Drag plane.class (the applet) to the line after ...
	4 Double-click on the applet placeholder.
	5 In the Java Applet Properties dialog box, set th...
	6 Click OK to close the dialog box.
	7 You can see the plane applet come to life in you...
	8 Switch back to Edit mode by choosing View > Page...


	Adding the interactive slide show
	To insert the slide show applet:
	1 Drag SlideShow.class from the Local Site window ...
	2 Open the Java Applet Properties dialog box by do...
	3 Set the dimensions of the applet to: Width 525 a...
	4 Click OK to close the dialog box.
	5 If you installed the Java folder with the applic...
	6 If you didn’t install the Java folder, choose Vi...
	7 After you have satisfied yourself that the slide...
	8 Save your changes and close this Web page.



	Making the map clickable
	Marking the descriptions with anchors
	To mark each description’s title with an anchor:
	1 Open the Map.html Web page.
	2 Place your insertion point before the Bungbusi h...
	3 Choose Anchor from the Insert menu.
	4 In the Anchor Properties dialog box, type Bungbu...
	5 Repeat steps 2-4 to create anchors for the other...


	Setting the map to function as an image map
	To change the island map to function as an image m...
	1 Open Map.html, if it is not already open.
	2 Choose View > Toolbars > Image Tools.
	3 Click on the map image, at the top of the Web pa...
	4 Use the rectangle drawing tool to outline the lo...


	Linking the towns to their descriptions
	To link the towns to the corresponding anchors:
	1 Double-click the Bungbusi rectangle to open the ...
	2 Click on the Anchor drop-down arrow and select B...
	3 Click OK to close the dialog box.
	4 Repeat steps 1-3 with the anchors and selection ...
	5 After you save the changes, you can try out the ...



	Creating the Home page
	Opening the new page — with frames
	To create the Amazing Adventures Home page:
	1 Select New Frame Set from the File menu.
	2 Choose Save Frame Set As from the File menu, to ...


	Setting up the Home page Table of Contents
	To assign a Web page to display in the TOC frame:
	1 The Home page (Home.html) should still be open. ...
	2 From the Frame menu, choose Set Frame Source.
	3 Navigate to HomeTOC.html (it’s at the root level...
	4 Resize the frames so your Web page looks proport...


	Setting up the opening page display
	To assign the opening Web page to display in the c...
	1 Select the content display frame (on the right) ...
	2 From the Frame menu, choose Set Frame Source.
	3 Using the dialog box, navigate to Opener.html (i...



	Creating a working Table of Contents
	Linking Web pages to the Table of Content icons
	To link the TOC icons:
	1 Open the Local Site window and position it so it...
	2 Click on a Home page TOC icon (in the left frame...
	3 Drag the Web page file corresponding to the icon...
	4 Repeat steps 2-3 until all the icons are linked....
	5 Make sure to save your changes.
	6 Switch to Preview mode by choosing Preview View ...
	7 In Preview mode, click once on any linked icon.
	8 Except for the Home page, close all the other op...
	9 Choose View > Page to switch back to Edit mode.


	Setting the display destination of the TOC links
	To set a display target for the TOC icons:
	1 The Home.html file should still be open.
	2 Click once in a blank area of the TOC frame to s...
	3 Choose Edit > Properties > Page.
	4 In the Page Properties dialog box, click on Sele...
	5 In the Base Target dialog box, click on the fram...
	6 Click OK to close the Base Target dialog box.
	7 Set the Title in the Page Properties dialog box ...
	8 Click OK to close the Page Properties dialog box...


	Testing the Home page Table of Contents
	Previewing links in the Home page:
	1 With the Home page still open, switch to Preview...
	2 Move the pointer over the Island Map and Informa...
	3 Click on the icon.
	4 Repeat steps 2-3 for all the icons in the Home p...
	5 Save your changes.
	6 When you display the Custom and Package Tours We...
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